Restoring wallet from seed - my old address is not shown


#1

I started mining beam with desktop wallet and created a new non-expiring address X. Then I migrated to linux CLI node and CLI wallet.

I have the node up, running, synced. I restored wallet from seed https://documentation.beam.mw/en/agile-atom-4194/rtd_pages/user_backup_restore.html#restore-cli-wallet-from-seed-phrase

I started the wallet listener. Now I see my beams.

However, ./beam-wallet address_list doesn’t show my original mining address X. I tried to create a new non-expiring mining address, but it didn’t generate the old one.

The old windows desktop wallet is no longer running.

My questions are these:

  1. Am I in control of my funds? They are listed as available and unspent, but I didn’t try to send them elsewhere.
  2. when somebody uses the old address X to send me BEAM, will I still receive them?
  3. why is it that wallet listener immediately found and listed my old mining address in the console logs, processed it, but it’s still not shown in address_list? Is this a bug?

Using latest release (agile-atom-1.1.4194)

Thank you! :slight_smile:


#2

Try the new wallet 1.1.4.201. I know there was an issue with 1.1.4194 and failed transactions with addresses because i wasn’t seen my BEAM either, but once i updated to the new wallet it got resolved automatically.

Here’s the release notes; https://medium.com/beam-mw/mimblewimble-hotfix-agile-atom-114194-83346acbe0f6


#3

Looks like there’s an even newer wallet now 1.1.4.202


#4

Hello, thank you, I updated my wallet and node to latest right now! :slight_smile: I deleted everything and started from scratch using seed words. My wallet again generated completely different addresses, but I see my coins.

The same was asked and answered here it seems: Question regarding beam addresses

So I understand correctly that without wallet.db from other PC, I can’t restore my previous addresses? No big deal really, if I can control my funds :slight_smile: [I see them, so that should be ok! ;-)]

Thank you :slight_smile: